Industry-Wide US Toll-Free Delivery Issue
Incident Report for Transmit SMS
Resolved
US carriers have advised that the issue impacting Toll-Free SMS delivery has now been resolved.
Posted Nov 16, 2019 - 13:53 AEDT
Identified
Messaging to US recipients via Toll-Free numbers is currently significantly delayed due to an industry-wide outage stemming from carrier infrastructure problems. We are monitoring carrier updates for notification of a resolution.
Posted Nov 16, 2019 - 09:33 AEDT
This incident affected: USA (SMS, Virtual Mobile Numbers).